hd/hd-1.3.ebuild
2024-01-08 20:35:25 -06:00

33 lines
589 B
Bash

# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Hexdump program written in rust"
HOMEPAGE="https://git.ylink.one/corey/hd"
SRC_URI="https://git.ylink.one/corey/hd/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
S="${WORKDIR}"
RDEPEND="${DEPEND}"
src_compile() {
emake all
}
src_prepare() {
default
unpack ${P}.tar.gz
mv hd ${P}
mv ${P}/* ./
echo "pub const VERSION:&str=\"${PV}\";" > version.rs
cd "${S}/${P}"
}
src_install() {
emake DESTDIR="${D}" PREFIX=/usr install
}